Get the latest tech news

A made-up name is better than no name


In working on Chessbook recently, I often found myself referring to (position, move) pairs. Specifically positions that are stored as EPDs, and moves that are stored in San notation. let difficulty_by_epd_san = //...; let existing_epd_sans = //...; let unique_moves_by_epd_san = //...; fn epd_san_plus_to_condition((epd, san_plus): &(String, String)) -> _ //...; I got so used to thinking of these things together as pairs, and wished I had a name for it. I couldn’t think of an existing name that worked well and wasn’t a mouthful like MoveFromPosition.

In working on Chessbook recently, I often found myself referring to (position, move) pairs. It’s a short, made-up name to nicely refer to a position string and a move notation. An(epd, san_plus) pair took up two slots in working memory, a Kep takes up one.

Get the Android app

Or read this on Hacker News